« 何を企んでるか推測してください… 02 | トップページ | 何を企んでるか推測してください… 03 »

C4D レンダリングした画像の生成されたα

気が付くと、artist side C4Dコミュで質問されていた…
「レンダリングされた画像のα」

読解力が低下した自分の頭では…
「α付きのマテリアルを適用してもオブジェクトが透過されず、空オブジェクトがレンダリングされない。」
等と勘違いしたのだ…
Alfa_19

もう回答されているので、問題ないのだけど…
もし、自分が回答していたら、トンチンカンな回答になっていただろう…

以前から、空オブジェクトや背景オブジェクトが追加されたシーンをα付きでレンダリングすると、思ったようなαにならない事は、古いユーザなら知っている事だろう。

でも、もう一つの回答が「そんな現象は起こらない…」と告げている…

R9.5からバージョンアップしていないので、最近のバージョンの事は詳しくわからない…
最近α付きレンダリングもしていないし…

R9.5では、空オブジェクト等が追加されたシーンでは、正確なαが出力されない事は知っていたから、気にも留めていませんでした…

バージョンアップ等で解消されたのだろうか…?
それとも、レンダラー毎に出力結果が違うのか…?

自分のC4D R9.5 は、空オブジェクト込みのレンダリング後のαは正確には生成されません。

では、できる範囲で確認してみます。
テストシーンは単純です。

「TestA_01.ZIP」

Alfa_28

Alfa_27

R9.5では…
Alfa_11 Alfa_12

このαが不思議なのは、αで透過された空オブジェクトの部分。
空オブジェクトのマテリアルのカラーチャンネルがαに適用されている事です。
透過されないなら、白一色になると思うのだけど…

Alfa_31

では、R10 Demoでは…
Alfa_13 Alfa_14

R9.5と同じです…

R11 Demoでは…
Alfa_15 Alfa_16

R11.5 Demoでは…
Alfa_17 Alfa_18

バージョンによっての差はありません…
RGBはマテリアルのαチャンネルで設定した通りに透過されています。

さて…この状態でコンポジットタグ(R9.5ではレンダリングタグ)で、空オブジェクトに「透過から見える」をOffに…

「TestA_02.ZIP」

Alfa_29

Alfa_30

R9.5
Alfa_19 Alfa_20

αチャンネルは良いけど…RGBが透過されません…
これでは、RGBが使い物になりません…
これで、「カメラから見える」もOffにすると空オブジェクトはRGBから無くなってしまいますが…?

R10 Demo
Alfa_21 Alfa_22

R11Demo
Alfa_23 Alfa_24

R11.5 Demo
Alfa_25 Alfa_26

全部同じ結果に…バージョンアップで解消されたわけではないようで…

他のレンダラー等では…?
FinalRenderとかV-Rayとか…?Maxwellとか…?
自分には確かめる術は無し…

できれば、空オブジェクト等が追加されたシーンのレンダリング画像は、こんなRGBとαが生成されていると良いわけで…

Alfa_11  Alfa_20

α付きでレンダリングしているなら、空/背景オブジェクトは必要ないのでは…?
そう思う人もいる事でしょう…

これは、ビデオ素材に対してのスーパーインポーズ用の合成素材としても使えるし、背景込みの完成された状態でも使えるし…

1つの動画で2通りの使い方ができる「一粒で2度美味しい」状態というわけです。

あ…、動画とは限りませんね…

|

« 何を企んでるか推測してください… 02 | トップページ | 何を企んでるか推測してください… 03 »